PT-2021-20535
CVE-2021-34539
·
Published
2021-06-10
·
Updated
2022-07-12
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
CubeCoders AMP versions prior to 2.1.1.8
Description:
The issue is related to a lack of validation of the Java Version setting, which allows an unintended executable path to be set. This results in high-privileged users being able to trigger code execution.
Recommendations:
For versions prior to 2.1.1.8, update to version 2.1.1.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the Java Version setting to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾