PT-2021-21089
CVE-2021-35970
·
Published
2021-06-30
·
Updated
2022-07-12
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions:
Talk 4 versions prior to 4.12.1
Description:
The issue allows remote attackers to discover e-mail addresses and other sensitive information via GraphQL because permission checks use an incorrect data type.
Recommendations:
For versions prior to 4.12.1, update to version 4.12.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the GraphQL endpoint to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾