PT-2021-21674
CVE-2021-3746
·
Published
2021-09-09
·
Updated
2022-06-02
Description by
CVSS 2.0
7.1
HighMetricsAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
libtpms versions prior to 0.8.5
libtpms versions prior to 0.7.9
libtpms versions prior to 0.6.6
Description
A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers. The issue is triggered by specially-crafted TPM2 command packets that affect the state of the TPM2's volatile state when written. The highest threat from this issue is to system availability.
Recommendations
For versions prior to 0.8.5, update to version 0.8.5 or later.
For versions prior to 0.7.9, update to version 0.7.9 or later.
For versions prior to 0.6.6, update to version 0.6.6 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾