PT-2021-22446

CVE-2021-39191

·

Published

2021-09-03

·

Updated

2025-12-29

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions mod auth openidc versions prior to 2.4.9.4
Description The mod auth openidc module for the Apache 2.x HTTP server is vulnerable to an open redirect attack. This occurs when a crafted URL is supplied in the target link uri parameter, affecting the 3rd-party init SSO functionality. A patch in version 2.4.9.4 applies the OIDCRedirectURLsAllowed setting to the target link uri parameter, mitigating the issue.
Recommendations For mod auth openidc versions prior to 2.4.9.4, upgrade to a patched version, specifically version 2.4.9.4 or later, to resolve the issue. As a temporary workaround, consider restricting the use of the target link uri parameter until a patch is applied. Additionally, ensure the OIDCRedirectURLsAllowed setting is properly configured to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2PGF-8H6H-GQG2
ALSA-2022:1823
AZL-7289
CESA-2022_1823
DLA-3499-1
OPENSUSE-SU-2023_0215-1
RHSA-2022:1823
RHSA-2022_1823
RLSA-2022:1823
SUSE-SU-2021:3352-1
SUSE-SU-2023:0215-1
SUSE-SU-2023_0215-1
SUSE-SU-2025:4532-1
Found an issue in the description? Have something to add? Feel free to write us 👾