PT-2021-22552

CVE-2021-39346

·

Published

2021-11-01

·

Updated

2021-11-02

Description by

CVSS 3.1
4.8
Medium
MetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Google Maps Easy WordPress plugin versions up to and including 1.9.33
Description: The issue arises from insufficient input validation and sanitization via several parameters in the ~/modules/marker groups/views/tpl/mgrEditMarkerGroup.php file, allowing attackers with administrative user access to inject arbitrary web scripts. This affects multi-site installations where unfiltered html is disabled for administrators, and sites where unfiltered html is disabled.
Recommendations: For versions up to and including 1.9.33, update to a version higher than 1.9.33 to resolve the issue. As a temporary workaround, consider restricting access to the ~/modules/marker groups/views/tpl/mgrEditMarkerGroup.php file to minimize the risk of exploitation. Additionally, ensure that unfiltered html is enabled for administrators in multi-site installations to prevent arbitrary web script injection.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾