PT-2021-22913

CVE-2021-40516

·

Published

2021-09-05

·

Updated

2022-03-27

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions WeeChat versions prior to 3.2.1
Description The issue allows remote attackers to cause a denial of service (crash) via a crafted WebSocket frame that triggers an out-of-bounds read in plugins/relay/relay-websocket.c in the Relay plugin.
Recommendations For versions prior to 3.2.1, update to version 3.2.1 or later to resolve the issue. As a temporary workaround, consider disabling the Relay plugin until a patch is available. Restrict access to the relay-websocket.c module to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2022-1588
DLA-2770-1
MGASA-2021-0466
OPENSUSE-SU-2022:0083-1
USN-5258-1
Found an issue in the description? Have something to add? Feel free to write us 👾