PT-2021-23059

CVE-2021-41038

·

Published

2021-11-10

·

Updated

2021-11-15

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions @theia/plugin-ext component of Eclipse Theia versions prior to 1.18.0
Description The issue allows Webview contents to be hijacked via the postMessage() function.
Recommendations For versions prior to 1.18.0, update to version 1.18.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the postMessage() function until a patch is available.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Related identifiers
GHSA-W6V7-W58J-PG5R
Found an issue in the description? Have something to add? Feel free to write us 👾