PT-2021-23702
CVE-2021-42972
·
Published
2021-12-07
·
Updated
2021-12-08
Description by
CVSS 3.1
8.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
NoMachine Server versions 4.0.346 through 7.7.4
Description
The issue allows local attackers to execute arbitrary code in kernel mode or cause a denial of service, such as memory corruption and OS crash, via specially crafted I/O Request Packet. This is due to a Buffer Overflow in the IOCTL Handler 0x22001B.
Recommendations
For NoMachine Server versions 4.0.346 through 7.7.4, update to version 7.7.4 or later to resolve the issue.
As a temporary workaround, consider restricting access to the IOCTL Handler 0x22001B to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾