PT-2021-23952

CVE-2021-43812

·

Published

2021-12-16

·

Updated

2021-12-22

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Auth0 Next.js SDK versions prior to 1.6.2
Description: The issue is related to the Auth0 Next.js SDK, a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, exposing the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.
Recommendations: Upgrade to version 1.6.2 or later, as this version contains the necessary fix for the issue. This update will not affect users.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2MQV-4J3R-VJVP
Found an issue in the description? Have something to add? Feel free to write us 👾