PT-2021-24043
CVE-2021-44145
·
Published
2021-12-17
·
Updated
2025-09-12
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions:
Apache NiFi versions prior to 1.15.1
Description:
The issue allows an authenticated user to configure an XSLT file in the TransformXML processor, which may include malicious external entity calls, potentially revealing sensitive information.
Recommendations:
For versions prior to 1.15.1, update to version 1.15.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the TransformXML processor to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾