PT-2021-24394

Published

2021-02-25

·

Updated

2021-02-25

Description by

Score
N/A
Not available

No severity ratings or metrics are available. When they are, we'll update the corresponding info on the page.

Name of the Vulnerable Software and Affected Versions: nodejs-marked versions 0.5.0 through 0.6.0
Description: A flaw was found in the package, making affected versions vulnerable to Regular Expression Denial of Service (ReDoS). The issue occurs when input to the host variable contains parentheses in link URIs, combined with a high number of link tokens in a single line.
Recommendations: For nodejs-marked versions 0.5.0 through 0.6.0, update to version 0.6.1 or later to resolve the issue.
Vendors
Affected products
Related identifiers
GHSA-7M7Q-Q53V-J47V
Found an issue in the description? Have something to add? Feel free to write us 👾