PT-2021-2549

CVE-2020-36313

·

Published

2020-06-04

·

Updated

2021-06-07

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Linux kernel versions prior to 5.7
Description: The issue is caused by a buffer overflow in the Kernel-based Virtual Machine (KVM) subsystem of the Linux kernel, specifically affecting components arch/s390/kvm/kvm-s390.c, include/linux/kvm host.h, and virt/kvm/kvm main.c. This allows an attacker to impact the confidentiality, integrity, and availability of protected information. The KVM subsystem permits out-of-range access to memslots after a deletion.
Recommendations: For versions prior to 5.7, update to version 5.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the KVM subsystem until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2020-2098
ALT-PU-2020-2164
ALT-PU-2020-2209
ALT-PU-2020-2409
ALT-PU-2020-2432
ALT-PU-2020-2687
ALT-PU-2021-1621
ALT-PU-2021-1656
ALT-PU-2021-1739
ALT-PU-2021-1862
ALT-PU-2021-1866
ALT-PU-2021-1870
Found an issue in the description? Have something to add? Feel free to write us 👾