PT-2021-2804

CVE-2021-21230

·

Published

2021-04-13

·

Updated

2025-02-14

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Google Chrome versions prior to 90.0.4430.93 Microsoft Edge (affected versions not specified)
Description The issue is related to a type confusion in the V8 JavaScript engine, which can lead to heap corruption. A remote attacker can potentially exploit this issue via a crafted HTML page, allowing for arbitrary code execution. The problem is associated with accessing a resource through incompatible types.
Recommendations For Google Chrome versions prior to 90.0.4430.93, update to version 90.0.4430.93 or later to resolve the issue. For Microsoft Edge, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
Exploitability
Exploit
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2021-1876
ALT-PU-2021-1972
ALT-PU-2021-2007
ALT-PU-2021-2009
ALT-PU-2021-2141
DSA-4911-1
OPENSUSE-SU-2021:0629-1
OPENSUSE-SU-2021_0629-1
OPENSUSE-SU-2021:0729-1
OPENSUSE-SU-2021_0729-1
OPENSUSE-SU-2024:10681-1
OPENSUSE-SU-2024:12948-1
Found an issue in the description? Have something to add? Feel free to write us 👾