PT-2021-2900

CVE-2021-2304

·

Published

2021-04-20

·

Updated

2021-12-31

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:S/C:N/I:P/A:C
Name of the Vulnerable Software and Affected Versions Oracle MySQL Server versions 8.0.23 and prior
Description The issue is related to insufficient input validation in the Server: Stored Procedure component of Oracle MySQL Server. This allows a high-privileged attacker with network access via multiple protocols to compromise the MySQL Server. Successful attacks can result in unauthorized access to modify, add, or delete data, as well as cause a hang or frequently repeatable crash (complete DOS) of the MySQL Server.
Recommendations For Oracle MySQL Server versions 8.0.23 and prior, update to a version later than 8.0.23 to resolve the issue. As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation. Additionally, restrict access to the Server: Stored Procedure component to prevent unauthorized modification, addition, or deletion of data.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2021:3590
ALT-PU-2021-1686
ALT-PU-2021-2380
ALT-PU-2021-3668
CESA-2021_3590
OESA-2021-1199
RHSA-2021:3590
RHSA-2021_3590
RHSA-2021:3811
RLSA-2021:3590
USN-4952-1
Found an issue in the description? Have something to add? Feel free to write us 👾