PT-2021-3107
CVE-2021-28652
·
Published
2021-05-10
·
Updated
2026-10-22
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Squid versions prior to 4.15
Squid versions 5.x prior to 5.0.6
Description
The issue is related to incorrect parser validation in the Cache Manager API, allowing a Denial of Service attack. A trusted client can trigger memory leaks over time, leading to a Denial of Service via an unspecified short query string. This attack is limited to clients with Cache Manager API access privilege.
Recommendations
For Squid versions prior to 4.15, update to version 4.15 or later to resolve the issue.
For Squid versions 5.x prior to 5.0.6, update to version 5.0.6 or later to resolve the issue.
As a temporary workaround, consider restricting access to the Cache Manager API to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾