PT-2021-3108

CVE-2021-28662

·

Published

2021-05-10

·

Updated

2024-06-15

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions Squid versions 4.x through 4.14 Squid versions 5.x through 5.0.5
Description An issue was discovered in Squid where a remote server can send a certain response header over HTTP or HTTPS, leading to a denial of service. This header can plausibly occur in benign network traffic. The vulnerability exists due to insufficient input validation when processing HTTP responses, allowing a remote attacker to cause a denial of service.
Recommendations For Squid versions 4.x through 4.14, update to version 4.15 or later. For Squid versions 5.x through 5.0.5, update to version 5.0.6 or later. As a temporary workaround, consider restricting access to the HTTP and HTTPS protocols to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-JJQ6-MH2H-G39H
ALSA-2021:4292
ALT-PU-2021-2058
ALT-PU-2021-2829
CESA-2021_4292
DSA-4924-1
MGASA-2021-0237
OESA-2021-1240
OPENSUSE-SU-2021:0879-1
OPENSUSE-SU-2021_0879-1
OPENSUSE-SU-2021:1961-1
OPENSUSE-SU-2021_1961-1
OPENSUSE-SU-2024:11403-1
RHSA-2021:4292
RHSA-2021_4292
RLSA-2021:4292
SUSE-SU-2021:1838-1
SUSE-SU-2021:1961-1
USN-4981-1
Found an issue in the description? Have something to add? Feel free to write us 👾