PT-2021-3347
CVE-2021-21702
·
Published
2021-02-08
·
Updated
2026-07-06
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions 7.3.x through 7.3.26
PHP versions 7.4.x through 7.4.14
PHP versions 8.0.x through 8.0.1
Description
The issue is related to pointer dereference errors in the PHP SOAP extension. A malicious SOAP server could return malformed XML data, causing PHP to access a null pointer and resulting in a crash. This could allow a remote attacker to cause the application to terminate unexpectedly.
Recommendations
For PHP versions 7.3.x through 7.3.26, update to version 7.3.27 or later.
For PHP versions 7.4.x through 7.4.14, update to version 7.4.15 or later.
For PHP versions 8.0.x through 8.0.1, update to version 8.0.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾