PT-2021-3362

CVE-2021-3560

·

Published

2021-06-03

·

Updated

2026-09-24

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Polkit versions prior to 0.119
Description It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this issue is to data confidentiality and integrity as well as system availability. The polkit system bus name get creds sync() function of the dbus-daemon library is associated with insufficient access control, allowing an attacker to elevate their privileges.
Recommendations Polkit version prior to 0.119: Update to Polkit version 0.119 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2021-1924
ALT-PU-2021-1997
ALT-PU-2021-2854
CESA-2021_2238
ELSA-2021-2238
MGASA-2021-0244
OESA-2021-1230
OPENSUSE-SU-2021:0838-1
OPENSUSE-SU-2021_0838-1
OPENSUSE-SU-2021:1843-1
OPENSUSE-SU-2021_1843-1
OPENSUSE-SU-2024:11180-1
RHSA-2021:2236
RHSA-2021:2237
RHSA-2021:2238
RHSA-2021_2238
RHSA-2021:2522
RHSA-2021:2555
RLSA-2021:2238
RLSA-2021_2238
SUSE-SU-2021:1842-1
SUSE-SU-2021_1842-1
SUSE-SU-2021:1843-1
SUSE-SU-2021_1843-1
SUSE-SU-2021:1844-1
SUSE-SU-2021_1844-1
USN-4980-1
Found an issue in the description? Have something to add? Feel free to write us 👾