PT-2021-3447
CVE-2021-24192
·
Published
2021-05-14
·
Updated
2022-07-30
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Tree Sitemap WordPress plugin versions prior to 2.9
Description
The issue is related to the
cp plugins do button job later callback AJAX action in the Tree Sitemap WordPress plugin, which is associated with authorization procedure errors. This can be exploited by low-privileged users to install any plugin, including specific versions, from the WordPress repository and activate arbitrary plugins from the blog. This could lead to more critical vulnerabilities, such as remote code execution (RCE).Recommendations
For versions prior to 2.9, update to version 2.9 or later to resolve the issue.
As a temporary workaround, consider disabling the
cp plugins do button job later callback AJAX action until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾