PT-2021-3603
CVE-2021-3426
·
Published
2020-05-05
·
Updated
2026-10-14
Description by
CVSS 3.1
5.7
MediumMetricsAV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Python versions prior to 3.8.9
Python versions prior to 3.9.3
Python versions prior to 3.10.0a7
Description
The issue is related to a flaw in Python 3's pydoc, which could allow a local or adjacent attacker to access sensitive information belonging to another user by starting a pydoc server. This flaw poses a high risk to data confidentiality.
Recommendations
For versions prior to 3.8.9, update to version 3.8.9 or later.
For versions prior to 3.9.3, update to version 3.9.3 or later.
For versions prior to 3.10.0a7, update to version 3.10.0a7 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾