PT-2021-3613
CVE-2021-26937
·
Published
2021-02-09
·
Updated
2024-06-15
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
GNU Screen versions through 4.8.0
Description
The issue is related to incorrect handling of UTF-8 character sequences in the encoding.c component of GNU Screen. This can be exploited by a remote attacker to gain access to confidential data, compromise data integrity, and cause a denial of service, potentially leading to an application crash.
Recommendations
For GNU Screen versions through 4.8.0, update to a version later than 4.8.0 to resolve the issue.
At the moment, there is no information about a newer version that contains a fix for this vulnerability.
Exploitability
Exploit
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾