PT-2021-3617
CVE-2021-36374
·
Published
2021-07-14
·
Updated
2026-10-15
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Apache Ant versions prior to 1.9.16
Apache Ant versions prior to 1.10.11
Description
The issue is related to an uncontrolled resource consumption in Apache Ant. It can be exploited by a remote attacker to cause a denial of service. When Apache Ant reads a specially crafted ZIP archive or derived formats, it can allocate large amounts of memory, leading to an out of memory error, even with small inputs. This can disrupt builds using Apache Ant. Derived formats from ZIP archives, such as JAR files and many office files, are also affected.
Recommendations
For Apache Ant versions prior to 1.9.16, update to version 1.9.16 or later.
For Apache Ant versions prior to 1.10.11, update to version 1.10.11 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾