PT-2021-4023
CVE-2021-37557
·
Published
2021-04-02
·
Updated
2021-08-10
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Centreon versions prior to 20.04.14
Centreon versions prior to 20.10.8
Centreon versions prior to 21.04.2
Description
A SQL injection vulnerability in image generation allows remote authenticated attackers to execute arbitrary SQL commands via the
index parameter in the include/views/graphs/generateGraphs/generateImage.php script. This vulnerability can be exploited by low-privileged attackers.Recommendations
For versions prior to 20.04.14, update to version 20.04.14 or later.
For versions prior to 20.10.8, update to version 20.10.8 or later.
For versions prior to 21.04.2, update to version 21.04.2 or later.
As a temporary workaround, consider restricting access to the include/views/graphs/generateGraphs/generateImage.php script to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾