PT-2021-4105
CVE-2021-31155
·
Published
2021-03-17
·
Updated
2022-07-12
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
pleaser versions prior to 0.4.0
Description
The issue is related to a failure to normalize the umask in the please utility, which can allow a local attacker to gain full root privileges if they are allowed to execute at least one command. This can lead to unauthorized access to confidential data, disruption of data integrity, and denial of service.
Recommendations
For versions prior to 0.4.0, update to version 0.4.0 or later to resolve the issue. As a temporary workaround, consider restricting the execution of commands that utilize the please utility to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾