PT-2021-4232
CVE-2021-32399
·
Published
2021-04-23
·
Updated
2025-06-18
Description by
CVSS 3.1
7.0
HighMetricsAV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions through 5.12.2
Description
The issue is caused by a race condition in the net/bluetooth/hci request.c component of the Linux operating system, resulting from concurrent execution with shared resources and improper synchronization. This can allow an attacker to execute arbitrary code.
Recommendations
For Linux kernel versions through 5.12.2, update to a version later than 5.12.2 to resolve the issue.
As a temporary workaround, consider restricting access to the net/bluetooth/hci request.c component until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾