PT-2021-4233
CVE-2021-33034
·
Published
2021-03-22
·
Updated
2023-05-17
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.12.4
Description
The issue is related to a use-after-free in the net/bluetooth/hci event.c component of the Linux kernel, specifically when destroying an hci chan. This can lead to writing an arbitrary value, potentially allowing an attacker to execute arbitrary code.
Recommendations
For Linux kernel versions prior to 5.12.4, update to version 5.12.4 or later to resolve the issue.
As a temporary workaround, consider restricting access to the net/bluetooth/hci event.c component until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾