PT-2021-4277
CVE-2021-33896
·
Published
2021-06-07
·
Updated
2026-10-01
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Dino versions 0.1.2 and earlier
Dino versions 0.2.x before 0.2.1
Description
The issue is related to an error with URI-encoded path separators, allowing for Directory Traversal, but only for the creation of new files. This could potentially allow a remote attacker to impact data integrity.
Recommendations
For Dino versions 0.1.2 and earlier, update to version 0.1.2 or later.
For Dino versions 0.2.x before 0.2.1, update to version 0.2.1 or later.
As a temporary workaround, consider restricting the use of URI-encoded path separators until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾