PT-2021-4338
CVE-2021-32675
·
Published
2021-10-04
·
Updated
2026-09-18
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Redis versions prior to 5.0.14
Redis versions prior to 6.0.16
Redis versions prior to 6.2.6
Description
The issue is related to errors in processing Redis Standard Protocol (RESP) requests, which can cause the server to allocate a significant amount of memory when specially crafted requests are delivered over multiple connections. This can be exploited by unauthenticated users because the same parsing mechanism is used to handle authentication requests.
Recommendations
For versions prior to 5.0.14, update to version 5.0.14 or later.
For versions prior to 6.0.16, update to version 6.0.16 or later.
For versions prior to 6.2.6, update to version 6.2.6 or later.
As a temporary workaround, consider blocking access to prevent unauthenticated users from connecting to Redis by using network access control tools like firewalls, iptables, security groups, etc., or by enabling TLS and requiring users to authenticate using client-side certificates.
Found an issue in the description? Have something to add? Feel free to write us 👾