PT-2021-4577
CVE-2021-22116
·
Published
2021-04-07
·
Updated
2026-09-20
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RabbitMQ versions prior to 3.8.16
Description
The issue is related to improper input validation in the AMQP 1.0 client connection endpoint, which can lead to a denial of service. A malicious user can exploit this by sending malicious AMQP messages to a RabbitMQ instance with the AMQP 1.0 plugin enabled.
Recommendations
For versions prior to 3.8.16, update to version 3.8.16 or later to resolve the issue. As a temporary workaround, consider disabling the AMQP 1.0 plugin until a patch is available. Restrict access to the AMQP 1.0 client connection endpoint to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾