PT-2021-4600
CVE-2021-3518
·
Published
2021-04-22
·
Updated
2026-10-14
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libxml2 versions prior to 2.9.11
Description
The issue is related to a use-after-free flaw in the xinclude.c component of the libxml2 library, which can be triggered by a specially crafted file. This can allow a remote attacker to access confidential data, compromise data integrity, and cause a denial of service. The flaw affects confidentiality, integrity, and availability.
Recommendations
For versions prior to 2.9.11, update to version 2.9.11 or later to resolve the issue.
As a temporary workaround, consider restricting the processing of crafted files by applications linked with libxml2 until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾