PT-2021-4756
CVE-2021-43389
·
Published
2021-09-24
·
Updated
2026-10-19
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.14.15
Description
An issue was discovered in the Linux kernel, specifically an array-index-out-of-bounds flaw in the
detach capi ctr function in drivers/isdn/capi/kcapi.c. This flaw can lead to a buffer overflow in memory, potentially allowing an attacker to cause a denial of service.Recommendations
For Linux kernel versions prior to 5.14.15, update to version 5.14.15 or later to resolve the issue. As a temporary workaround, consider restricting access to the
detach capi ctr function in the kcapi.c driver to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾