PT-2021-4905

CVE-2021-35982

·

Published

2021-09-14

·

Updated

2022-02-01

Description by

CVSS 3.1
7.3
High
MetricsAV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Adobe Acrobat Reader DC versions 2021.005.20060 and earlier Adobe Acrobat Reader DC versions 2020.004.30006 and earlier Adobe Acrobat Reader DC versions 2017.011.30199 and earlier
Description The issue is related to an Uncontrolled Search Path Element vulnerability, which can be exploited by a local attacker with non-administrative privileges to achieve arbitrary code execution in the context of the current user via DLL hijacking. This requires user interaction, such as opening a specially crafted PDF file. The vulnerability is associated with an unsafe procedure for searching paths to DLL libraries.
Recommendations For Adobe Acrobat Reader DC versions 2021.005.20060 and earlier, update to a version later than 2021.005.20060 to resolve the issue. For Adobe Acrobat Reader DC versions 2020.004.30006 and earlier, update to a version later than 2020.004.30006 to resolve the issue. For Adobe Acrobat Reader DC versions 2017.011.30199 and earlier, update to a version later than 2017.011.30199 to resolve the issue. As a temporary workaround, consider restricting the use of DLL libraries to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾