PT-2021-5535

CVE-2020-36221

·

Published

2021-01-25

·

Updated

2026-10-14

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions OpenLDAP versions prior to 2.4.57
Description The issue is related to an integer underflow in the OpenLDAP implementation, which can be exploited by a remote attacker to cause a denial of service. This is achieved by sending a specially crafted request that triggers a crash in the Certificate Exact Assertion processing, specifically in the serialNumberAndIssuerCheck function within schema init.c. The exploitation can result in the slapd service crashing.
Recommendations For versions prior to 2.4.57, update to version 2.4.57 or later to resolve the issue. As a temporary workaround, consider restricting access to the Certificate Exact Assertion processing to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2021-1333
ALT-PU-2021-1352
ALT-PU-2021-1354
BIT-OPENLDAP-2020-36221
CLEANSTART-2026-HK58158
DLA-2544-1
DSA-4845-1
MGASA-2021-0105
OESA-2021-1062
OPENSUSE-SU-2021:0408-1
OPENSUSE-SU-2021_0408-1
ROSA-SA-2025-2550
SUSE-SU-2021:0692-1
SUSE-SU-2021_0692-1
SUSE-SU-2021:0693-1
SUSE-SU-2021_0693-1
SUSE-SU-2021:0723-1
SUSE-SU-2021_0723-1
SUSE-SU-2021:14700-1
SUSE-SU-2021_14700-1
USN-4724-1
USN-7698-1
Found an issue in the description? Have something to add? Feel free to write us 👾