PT-2021-5551
CVE-2020-36229
·
Published
2021-01-25
·
Updated
2026-10-14
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
OpenLDAP versions prior to 2.4.57
Description
The issue is related to an incompatible type access in the OpenLDAP protocol implementation. It allows a remote attacker to send a specially crafted request to slapd, potentially leading to a denial of service (DoS) attack. The flaw is in the ldap X509dn2bv function and affects the X.509 DN parsing in ad keystring, causing a slapd crash.
Recommendations
For OpenLDAP versions prior to 2.4.57, update to version 2.4.57 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable ldap X509dn2bv function until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾