PT-2021-6034
CVE-2022-23222
·
Published
2021-12-18
·
Updated
2026-10-18
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions 5.8 through 5.15.14
Description
The issue is related to errors in pointer dereferencing in the eBPF subsystem of the Linux kernel, allowing local users to gain privileges due to the availability of pointer arithmetic via certain * OR NULL pointer types.
Recommendations
For Linux kernel versions 5.8 through 5.15.14, update to version 5.10.92, 5.15.15, or 5.16.1 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾