PT-2021-6084
CVE-2021-42550
·
Published
2021-12-16
·
Updated
2026-09-23
Description by
CVSS 2.0
8.5
HighMetricsAV:N/AC:M/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
logback versions 1.2.7 and prior
Description
The issue is related to the deserialization mechanism in the logback library, which can be exploited by an attacker with the required privileges to edit configuration files. This could allow the execution of arbitrary code loaded from LDAP servers. An attacker could craft a malicious configuration to achieve this.
Recommendations
For logback versions 1.2.7 and prior, upgrade to version 1.2.8 and disable all the lookup code as a recommended fix. As a temporary workaround, consider restricting access to configuration files to prevent malicious edits. Additionally, disabling the use of LDAP servers for code loading can help minimize the risk of exploitation until the issue is fully resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾