PT-2021-6746
CVE-2021-27432
·
Published
2021-02-19
·
Updated
2021-06-01
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
OPC Foundation UA .NET Standard versions prior to 1.4.365.48
OPC UA .NET Legacy
Description
The issue is related to an uncontrolled recursion in the OPC UA .NET Standard and OPC UA .NET Legacy implementations, which may allow an attacker to trigger a stack overflow, potentially leading to a denial of service. This could be exploited by a remote attacker.
Recommendations
For OPC Foundation UA .NET Standard versions prior to 1.4.365.48, update to version 1.4.365.48 or later to resolve the issue.
For OPC UA .NET Legacy, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
Found an issue in the description? Have something to add? Feel free to write us 👾