PT-2021-7112
CVE-2021-2460
·
Published
2021-07-20
·
Updated
2021-07-21
Description by
CVSS 2.0
7.0
HighMetricsAV:N/AC:M/Au:S/C:C/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Oracle Application Express Data Reporter versions prior to 21.1.0.00.04
Description
The issue is related to insufficient input validation in the Oracle Application Express Data Reporter component of Oracle Database Server. This easily exploitable vulnerability allows a low-privileged attacker with a valid user account and network access via HTTP to compromise Oracle Application Express Data Reporter. Successful attacks require human interaction from a person other than the attacker and may significantly impact additional products. The vulnerability can result in unauthorized update, insert, or delete access to some of Oracle Application Express Data Reporter's accessible data, as well as unauthorized read access to a subset of Oracle Application Express Data Reporter's accessible data.
Recommendations
For versions prior to 21.1.0.00.04, update to version 21.1.0.00.04 or later to resolve the issue. As a temporary workaround, consider restricting access to the Oracle Application Express Data Reporter component to minimize the risk of exploitation. Additionally, ensure that all inputs are thoroughly validated to prevent unauthorized access.
Found an issue in the description? Have something to add? Feel free to write us 👾