PT-2021-7118
CVE-2021-4023
·
Published
2021-09-16
·
Updated
2026-08-23
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.15-rc1
Description
The issue is related to the io-workqueue implementation in the Linux kernel, which lacks protection of internal data. This can be exploited to cause a denial of service. A local user with permissions to execute io-uring requests can potentially crash the system by triggering the submission of new io-uring operations during a shortage of free space, leading to a kernel panic.
Recommendations
For Linux kernel versions prior to 5.15-rc1, update to version 5.15-rc1 or later to resolve the issue. As a temporary workaround, consider restricting access to io-uring requests to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾