PT-2021-7354
CVE-2021-3607
·
Published
2021-06-17
·
Updated
2024-06-15
Description by
CVSS 3.1
6.0
MediumMetricsAV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
QEMU versions prior to 6.1.0
Description
The issue is related to an integer overflow in the QEMU implementation of VMWare's paravirtual RDMA device. It occurs due to improper input validation while handling a "PVRDMA REG DSRHIGH" write from the guest. This allows a privileged guest user to cause QEMU to allocate a large amount of memory, resulting in a denial of service. The highest threat from this issue is to system availability.
Recommendations
For versions prior to 6.1.0, update to version 6.1.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the paravirtual RDMA device to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾