PT-2021-7360
CVE-2021-42008
·
Published
2021-05-18
·
Updated
2025-09-29
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.13.13
Description
The issue is related to a slab out-of-bounds write in the decode data function of the drivers/net/hamradio/6pack.c component in the Linux kernel. This can be exploited to gain access to confidential data, compromise data integrity, and cause a denial of service. Input from a process with the CAP NET ADMIN capability can lead to root access. The vulnerability is a 16-year-old heap OOB write in the N 6PACK tty line discipline.
Recommendations
For Linux kernel versions prior to 5.13.13, update to version 5.13.13 or later to resolve the issue. As a temporary workaround, consider restricting access to the
decode data function in the drivers/net/hamradio/6pack.c component until a patch is available. Additionally, limiting the use of the CAP NET ADMIN capability can help minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾