PT-2021-7478

CVE-2021-31684

·

Published

2021-04-16

·

Updated

2026-09-18

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions JSON Smart versions prior to 1.3.3 and 2.4.5
Description A vulnerability was discovered in the indexOf function of JSONParserByteArray in JSON Smart, which causes a denial of service (DOS) via a crafted web request. The issue is related to a buffer overflow in memory, allowing a remote attacker to cause a denial of service by sending specially crafted web requests.
Recommendations For versions prior to 1.3.3, update to version 1.3.3 or later. For versions prior to 2.4.5, update to version 2.4.5 or later. As a temporary workaround, consider disabling the indexOf function in JSONParserByteArray until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-FG2V-W576-W4V3
CLEANSTART-2026-GB22495
DLA-3373-1
ECHO-5ABF-EE02-406A
USN-6011-1
Found an issue in the description? Have something to add? Feel free to write us 👾