PT-2021-7933

CVE-2021-28169

·

Published

2021-06-09

·

Updated

2025-08-05

Description by

CVSS 3.1
5.3
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions Eclipse Jetty versions <= 9.4.40 Eclipse Jetty versions <= 10.0.2 Eclipse Jetty versions <= 11.0.2
Description The vulnerability in the Eclipse Jetty servlet container is related to the lack of protection for service data. Exploitation of this issue can allow a remote attacker to obtain confidential information. Specifically, requests to the ConcatServlet with a doubly encoded path can access protected resources within the WEB-INF directory. For example, a request to /concat?/%2557EB-INF/web.xml can retrieve the web.xml file, revealing sensitive information about the web application's implementation. This occurs due to the double decoding of the supplied path by the ConcatServlet and WelcomeFilter, allowing paths with a doubly encoded WEB-INF to bypass security checks.
Recommendations For Eclipse Jetty versions <= 9.4.40, update to version 9.4.41 or later. For Eclipse Jetty versions <= 10.0.2, update to version 10.0.3 or later. For Eclipse Jetty versions <= 11.0.2, update to version 11.0.3 or later. As a temporary workaround, consider deploying your own version of the ConcatServlet and/or the WelcomeFilter using the code from the latest version of Jetty.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-GWCR-J4WH-J3CQ
ALT-PU-2024-16002
ALT-PU-2024-16022
ALT-PU-2024-16072
DLA-2688-1
DSA-4949-1
OESA-2021-1249
OPENSUSE-SU-2021:2005-1
OPENSUSE-SU-2021_2005-1
OPENSUSE-SU-2024:10878-1
RHSA-2021:3758
SUSE-SU-2021:2005-1
Found an issue in the description? Have something to add? Feel free to write us 👾