PT-2021-8382

CVE-2015-20001

·

Published

2021-04-11

·

Updated

2021-04-22

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Rust versions prior to 1.2.0
Description The issue arises from the standard library in Rust, where the BinaryHeap is not panic-safe. When the comparison of generic elements inside sift up or sift down range panics, the binary heap is left in an inconsistent state. This can lead to a drop of zeroed memory as an arbitrary type, resulting in a memory safety violation.
Recommendations For versions prior to 1.2.0, update to version 1.2.0 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾