PT-2021-9147

CVE-2020-10519

·

Published

2021-03-03

·

Updated

2021-12-20

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions GitHub Enterprise Server versions prior to 2.22.7 GitHub Enterprise Server version 2.21.15 GitHub Enterprise Server version 2.20.24
Description A remote code execution issue was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. The user-controlled configuration of the underlying parsers used by GitHub Pages was not sufficiently restricted, making it possible to execute commands on the GitHub Enterprise Server instance. To exploit this issue, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance.
Recommendations For GitHub Enterprise Server versions prior to 2.22.7, update to version 2.22.7 or later to resolve the issue. For GitHub Enterprise Server versions prior to 2.21.15, update to version 2.21.15 or later to resolve the issue. For GitHub Enterprise Server versions prior to 2.20.24, update to version 2.20.24 or later to resolve the issue. As a temporary workaround, consider restricting access to GitHub Pages site creation and build permissions until a patch is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾