PT-2021-9171
CVE-2020-10716
·
Published
2021-05-27
·
Updated
2025-08-06
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:L/Au:S/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Red Hat Satellite tfm-rubygem-foreman ansible versions prior to 4.0.3.4
Description
A flaw in Red Hat Satellite's Job Invocation allows a malicious user to scan through the invocation, potentially searching for passwords and other sensitive data due to improper restriction of the "User Input" entry.
Recommendations
For tfm-rubygem-foreman ansible versions prior to 4.0.3.4, update to version 4.0.3.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the Job Invocation feature to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾