PT-2022-12449

CVE-2021-45886

·

Published

2022-03-13

·

Updated

2022-03-20

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PONTON X/P Messenger versions prior to 3.11.2
Description An issue was discovered where anti-CSRF tokens are globally valid, making the web application vulnerable to a weakened version of CSRF. This allows an arbitrary token of a low-privileged user, such as an operator, to be used to confirm actions of higher-privileged ones, such as xpadmin.
Recommendations For versions prior to 3.11.2, update to version 3.11.2 or later to resolve the issue. As a temporary workaround, consider restricting access to higher-privileged actions to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾