PT-2022-12994

CVE-2022-0145

·

Published

2022-03-24

·

Updated

2022-03-29

Description by

CVSS 3.1
6.8
Medium
MetricsAV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Fork CMS versions prior to 5.11.1
Description The issue is related to stored Cross-site Scripting (XSS) in the GitHub repository forkcms/forkcms. When uploading a new module, the description of the module can contain JavaScript code, which may be executed after uploading the new module and viewing the Details page. This allows for the potential execution of malicious scripts.
Recommendations For Fork CMS versions prior to 5.11.1, update to version 5.11.1 or later to resolve the issue. As a temporary workaround, consider restricting the ability to upload new modules or limiting the use of JavaScript code in module descriptions until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-QF2G-Q4MC-W7RR
Found an issue in the description? Have something to add? Feel free to write us 👾