PT-2022-13179

CVE-2022-0430

·

Published

2022-03-15

·

Updated

2025-04-23

Description by

CVSS 3.1
5.3
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions httpie versions prior to 3.1.0
Description The issue concerns exposure of sensitive information to unauthorized actors. httpie is a command-line HTTP client, and prior to version 3.1.0, all cookies saved to session storage are supercookies, which poses a security risk. There is no known workaround at this time.
Recommendations For versions prior to 3.1.0, update to version 3.1.0 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-6PC9-XQRG-WFQW
ALT-PU-2025-5823
PYSEC-2022-167
Found an issue in the description? Have something to add? Feel free to write us 👾