PT-2022-13195

CVE-2022-0451

·

Published

2022-02-18

·

Updated

2022-02-26

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Dart SDK versions prior to 2.16.0
Description The Dart SDK contains an HTTPClient in the dart:io library that includes authorization headers when handling cross-origin redirects. These headers may be explicitly set and contain sensitive information. By default, HttpClient handles redirection logic. If a request is sent to a site with an authorization header and it redirects to an attacker's site, the attacker's site may receive the authorization header, potentially exposing sensitive information.
Recommendations Update the Dart SDK to version 2.16.0 or beyond.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾